You are viewing an old version of this page. View the current version.

Compare with Current View Page History

« Previous Version 4 Next »

Dear org.lcsim developers,

I would like to share some comments about the API from a user point-of-view. I hope that the comments will become more detailed, once I actually use it:

The use of double[] for Vectors and Shapes

I don't think this is a good idea. While I appreciate that the description is in the javadoc, I strongly feel that it should be part of the API. For vectors, this might still be acceptable, while for shapes I find it absolutely necessary to have descriptive names. The mapping between index and name of the parameter is totally arbitrary and should therefore be avoided completely.

The API for the analysis should be as high-level as possible. I would therefore very much appreciate if classes for the vectors and shapes and track parameters could be added. No, they don't need Draw(), Rotate(), Pt() and Streamer components (wink)

Status codes

The Java language was awarded such a nice enum class. Is there really a performance issue in using ints for status bits or types ?

/** Type of hit. Mapping of integer types to type names
  * through collection parameters "TrackerHitTypeNames"
  * and "TrackerHitTypeValues".
  */

Examples:

  • the FitStatus class
  • in FtfTrack.java: if ( getPara().szFitFlag == 1 )
    especially the latter class would benefit from using enums or at least symbolic constants, if the author ever wants to hand over maintenance to someone else.

This does not help me at all when I am coding, and I don't want to have a web browser open all the time to see what the type, status, flag, whatever, actually stands for. This is where I would like to take advantage of Code Completion.

org.lcsim.mc.fast.cluster.ronan

I disagree with the use of names for packages.

JavaDoc

The class TrackVector shouldn't have te, tv, td in the Javadoc. This is cryptic. It is actually clearer to browse the source code than to read the javadoc

"Overloaded Operators"

It is very confusing to have members like add(Object o1, Object o2) as members of the classes. This is counter-intuitive. Either there ought to be a supporter class with static members only, or the member of the type class expects only one argument.
So:
vec1.add(vec1, vec2) #BAD
vec1.add(vec2) #GOOD
import static x.y.add; add(vec1, vec2); #GOOD

Thank you for your consideration
Jan

  • No labels