Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

getTrackParameters() should return a small class that contains accessors by name.
You might consider this nitpicking, but there should be a naming convention. The function name getTrackParameters is unnecessarily long. Of course it returns Track Parameters. It's a Track Interface. This redundancy does not clarify the code and should therefore be removed. track.parameters() is sufficient in my view. Of course, if you give your variables names like fltTrkLstArray or similar obscurities, get Track Parameters would save you. But then you ought to be shot anyway.
There ought to be also a consistent use of get XXX() vs xxx()
getReferencePoint() should return a SpacePoint.

...

I disagree with the use of names that have no meaning outside of SLACfor packages.

JavaDoc

The class TrackVector shouldn't have te, tv, td in the Javadoc. This is cryptic. It is actually clearer to browse the source code .than to read the javadoc

"Overloaded Operators"

It is very confusing to have members like add(Object o1, Object o2) as members of the classes. This is counter-intuitive. Either there ought to be a supporter class with static members only, or the member of the type class expects only one argument.
So:
vec1.add(vec1, vec2) #BAD
vec1.add(vec2) #GOOD
import static x.y.add; add(vec1, vec2); #GOOD

...